This file describes de required Style Guide used by Basicamente to keep the Best Practices on develop new features or improve/change existents one.
Always follow the folder structure below:
src/
<!DOCTYPE html> | |
<html lang="en"> | |
<head> | |
<title>Fan Club List</title> | |
<meta charset="utf-8"> | |
<meta name="viewport" content="width=device-width, initial-scale=1"> | |
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css"> | |
<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.3.1/jquery.min.js"></script> | |
<script src="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/js/bootstrap.min.js"></script> | |
</head> |
package com.luv2code.springdemo.mvc.validation; | |
import java.lang.annotation.ElementType; | |
import java.lang.annotation.Retention; | |
import java.lang.annotation.RetentionPolicy; | |
import java.lang.annotation.Target; | |
import javax.validation.Constraint; | |
import javax.validation.Payload; |
//you do not necessary need all of the following, i copy/pasted a piece from | |
//one of my projects. | |
var express = require('express'); | |
var fs = require('fs'); | |
var Busboy = require('busboy'); | |
var mime = require('mime'); | |
var https = require('https'); | |
var querystring = require('querystring'); | |
var router = express.Router(); |
We have been going over a lot of naming conventions for our database. I would like to start recording the ideas and why they work/don't.
This applies to having an archived
state of an item. We attempted to draw a line at when a column is an action (e.g. archive
) rather than a property (e.g. is_red
). This idea means that we convert these "action" states to timestamp fields over booleans (e.g. archived_at: timestamp
).
In order to keep data consistent, we must introduce the timestamp from a single service. This means that we must introduce an alternative endpoint to performing this action (e.g. PUT /item/:id/archive
). This is fine but can lead to complications with pedantic REST frameworks.
There are a lot of options for column naming: