-
-
Save coldcue/ed7926b09e0feff4ec0c7e2304e4814f to your computer and use it in GitHub Desktop.
///// TODO : Replace <<LAN_INTERFACE>> with internal bridge or lan interface, replace <<<PPPOE_DIGI_INTERFACE>>> with the pppoe-digi interface | |
/ipv6 nd | |
set [ find default=yes ] disabled=yes | |
add advertise-dns=yes interface=<<LAN_INTERFACE>> | |
/ipv6 dhcp-client | |
add add-default-route=yes interface=<<<PPPOE_DIGI_INTERFACE>>> pool-name=pool6 request=address,prefix script=":del\ | |
ay 5s;\ | |
\n/ipv6 address remove [find advertise=yes]\ | |
\n/ipv6 address add interface=<<LAN_INTERFACE>> address=::1/64 from-pool=pool6 advertise=yes" use-peer-dns=no | |
/ipv6 firewall filter | |
add action=drop chain=input comment="Drop (invalid)" connection-state=invalid | |
add action=accept chain=input comment="Accept (established, related)" connection-state=established,related | |
add action=accept chain=input comment="Accept DHCP (10/sec)" in-interface-list=<<<PPPOE_DIGI_INTERFACE>>> limit=10,20:packet protocol=udp src-port=547 | |
add action=drop chain=input comment="Drop DHCP (>10/sec)" in-interface-list=<<<PPPOE_DIGI_INTERFACE>>> protocol=udp src-port=547 | |
add action=accept chain=input comment="Accept external ICMP (10/sec)" in-interface-list=<<<PPPOE_DIGI_INTERFACE>>> limit=10,20:packet protocol=icmpv6 | |
add action=drop chain=input comment="Drop external ICMP (>10/sec)" in-interface-list=<<<PPPOE_DIGI_INTERFACE>>> protocol=icmpv6 | |
add action=accept chain=input comment="Accept internal ICMP" in-interface-list=!<<<PPPOE_DIGI_INTERFACE>>> protocol=icmpv6 | |
add action=drop chain=input comment="Drop external" in-interface-list=<<<PPPOE_DIGI_INTERFACE>>> | |
add action=reject chain=input comment="Reject everything else" | |
add action=accept chain=output comment="Accept all" | |
add action=drop chain=forward comment="Drop (invalid)" connection-state=invalid | |
add action=accept chain=forward comment="Accept (established, related)" connection-state=established,related | |
add action=accept chain=forward comment="Accept external ICMP (20/sec)" in-interface-list=<<<PPPOE_DIGI_INTERFACE>>> limit=20,50:packet protocol=icmpv6 | |
add action=drop chain=forward comment="Drop external ICMP (>20/sec)" in-interface-list=<<<PPPOE_DIGI_INTERFACE>>> protocol=icmpv6 | |
add action=accept chain=forward comment="Accept internal" in-interface-list=!<<<PPPOE_DIGI_INTERFACE>>> | |
add action=accept chain=forward comment="Accept outgoing" out-interface-list=<<<PPPOE_DIGI_INTERFACE>>> | |
add action=drop chain=forward comment="Drop external" in-interface-list=<<<PPPOE_DIGI_INTERFACE>>> | |
add action=reject chain=forward comment="Reject everything else" |
In my case, ipv6 dhcp-client is stuck in searching
mode.. and pool6 is not created..
EDIT. Fixed it by triggering a pppoe interface restart by re-applying
the PPPOE settings
Also, on RouterOS v7.5 I had to replace in-interface-list
with in-interface
and out-interface-list
with out-interface
There is an error on line 11:
interface=bridge-lan
should beinterface=<<LAN_INTERFACE>>
. With that fixed, it works like a charm!
Thanks, fixed
tried this, but no luck. Stuck in "Searching"
Same, Stuck in "Searching"
Mine also gets stuck on "Searching". Has anyone managed to figure it out?
My fork is working for 6.48.4 (stable)
. If anyone finds a fix, please post a fork because I won't upgrade to ROS 7 without IPv6.
I suspect it's RouterOS 7 then. Has the issue been reported to Mikrotik?
Yes, I can confirm. It was caused by ROS 7. It works on the latest long-term release (6.49.13).
There is an error on line 11:
interface=bridge-lan
should beinterface=<<LAN_INTERFACE>>
. With that fixed, it works like a charm!