Skip to content

Instantly share code, notes, and snippets.

View jctmf's full-sized avatar
😍

João Carlos T. de Melo Filho jctmf

😍
  • Supptex Suporte e Tecnologia, Regalia Tecnologia
  • Recife-PE
  • 05:01 (UTC -03:00)
View GitHub Profile

For my reference in the future I will record here the steps that I had to follow in order to install Openwrt on the tp-link router EX220. This was done using a Windows 11 machine.

Disclaimer: Use this tutorial at your own risk. We are not responsible for any damage/harms done to your device using the information from this tutorial.

Steps to install OpenWRT on EX220 router

OEM installation using the serial + TFTP method

These are the steps provided at the official https://openwrt.org/toh/tp-link/ex220_v1 page:

@freedmand
freedmand / website_to_pdf.sh
Created April 17, 2023 12:48
Archives all pages of a specified website and outputs a single PDF file
#!/bin/bash
# Archives a specified website including all sub-pages and outputs a single PDF file
# Requires the following tools to be installed:
# - wget
# - wkhtmltopdf
# - gs (ghostscript)
# Installation:
@kheuser
kheuser / ubuntu2002_php559.sh
Last active May 22, 2024 20:16
Install php5.5.9 on Ubuntu 20.04
apt -y install build-essential libxml2-dev libxslt1-dev
apt -y install libfcgi-dev libfcgi0ldbl libjpeg62-dbg libxml2-dev
apt -y install libmcrypt-dev libssl-dev libc-client2007e libc-client2007e-dev
apt -y install libbz2-dev libcurl4-openssl-dev libjpeg-dev
apt -y install libfreetype6-dev libkrb5-dev libpq-dev libicu-dev
ln -s /usr/lib/libc-client.a /usr/lib/x86_64-linux-gnu/libc-client.a
mkdir /opt/php-5.5.9
mkdir /usr/local/src/php5-build
========= ========== ===== =====
========= ============ ====== ======
=== === ==== ===== =====
=== ========= ====== ====== INSTALLIN' THAT SWEET SWEET
=== ======== ============= BIG IRON ON YOUR LINUX LAPTOP
=== ========= ============= OR SERVER - BY MR. SKILLFULL
=== === ==== === === ===
========= ============ ===== = =====
========= ========== ===== =====
@dhcgn
dhcgn / routerboard.sh
Last active October 6, 2023 23:45
Add Cloudflare IPs to Mikrotik Routerboard
/ip firewall address-list
add list=CF address=173.245.48.0/20
add list=CF address=103.21.244.0/22
add list=CF address=103.22.200.0/22
add list=CF address=103.31.4.0/22
add list=CF address=141.101.64.0/18
add list=CF address=108.162.192.0/18
add list=CF address=190.93.240.0/20
add list=CF address=188.114.96.0/20
add list=CF address=197.234.240.0/22
@berkorbay
berkorbay / github_desktop_ubuntu.md
Last active April 21, 2025 00:30
To install Github Desktop for Ubuntu

IMPORTANT

See the following links for further updates to Github Desktop for Ubuntu. These are official instructions. (also mentioned by fetwar on Nov 3, 2023)

For the sake of "maintaining the tradition" here is the updated version.

@judero01col
judero01col / Service KMS
Last active April 20, 2025 14:31
Volume License Activation Key Service - KMS
## Find Available Target Editions
DISM.exe /Online /Get-TargetEditions
## Convert Server Standard 2019 Evaluation to Server Standard 2019
DISM /online /Set-Edition:ServerStandard /ProductKey:N69G4-B89J2-4G8F4-WWYCC-J464C /AcceptEula
## How To Activate
slmgr /ipk XXXXX-XXXXX-XXXXX-XXXXX-XXXXX
slmgr /skms [server]:[port]
slmgr /ato
@alexishida
alexishida / rtsp-intelbras-outros.txt
Last active April 17, 2025 15:50
RTSP dvr intelbras e outros para acesso direto home assistant
-------- DVR e Mibo Smart Intelbras -------------------------------------------------------
rtsp://usuário:senha@ip:porta/cam/realmonitor?channel=1&subtype=0
Ps minha mibo smart im4c só funcionou com esse link:
rtsp://admin:chave de acesso@ip:554/cam/realmonitor?channel=1&subtype=0&unicast=true&proto=Onvif
-------- Luxvision -------------------------------------------------------
rtsp://ip:porta/user=[usuário]&password=[senha]&channel=1&stream=0.sdp
@eyJhb
eyJhb / backup.sh
Created November 14, 2018 21:20
Simple script I use to backup my servers - uses PGP for encryption and SCP for uploading
#!/bin/bash
# Linux SCP Backup Script
# how it works
# -
#date string
d=$(date --iso)
@macbleser
macbleser / wp-permissions-script
Created February 21, 2014 15:37
WordPress Permissions Configuration Script
#!/bin/bash
#
# This script configures WordPress file permissions based on recommendations
# from http://codex.wordpress.org/Hardening_WordPress#File_permissions
#
# Author: Michael Conigliaro
#
WP_OWNER=changeme # <-- wordpress owner
WP_GROUP=changeme # <-- wordpress group
WP_ROOT=/home/changeme # <-- wordpress root directory