Created
February 13, 2024 11:34
-
-
Save kangarie/caf86607eab0c1659cb71fc427eec83f to your computer and use it in GitHub Desktop.
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
[Interface] | |
PrivateKey = RandomPrivateKey | |
Address = IPV4 | |
Address = IPV6 | |
DNS = 1.1.1.1, 1.0.0.1, 2606:4700:4700::1111, 2606:4700:4700::1001 | |
MTU = 1280 | |
[Peer] | |
PublicKey = RandomPublicKey | |
AllowedIPs = 0.0.0.0/0 | |
AllowedIPs = 2000::/3 | |
Endpoint = engage.cloudflareclient.com:2408 | |
/interface wireguard | |
add listen-port=13231 mtu=1420 name=WARP private-key="RandomPrivateKey" | |
/interface wireguard peers | |
add allowed-address=0.0.0.0/0,2000::/3 endpoint-address=engage.cloudflareclient.com endpoint-port=2408 interface=WARP public-key="RandomPublicKey" | |
/ip address | |
add address=IPV4 interface=WARP network=IPV4 | |
/routing table | |
add disabled=no fib name=toWARP | |
/ip firewall mangle | |
add action=mark-routing chain=prerouting comment=WARP_tcp dst-address-list=!LOCAL dst-port=80,443 new-routing-mark=toWARP passthrough=no protocol=tcp | |
add action=mark-routing chain=prerouting comment=WARP_tcp dst-address-list=!LOCAL dst-port=80,443 new-routing-mark=toWARP passthrough=no protocol=udp | |
/ip route | |
add disabled=no dst-address=0.0.0.0/0 gateway=WARP routing-table=toWARP | |
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment