This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
<?php | |
$encoded_string = "JATa2iUqVdzCkBP5RiyitlQlUiACl8UrpJOeGUJO"; | |
$cc_encryption_hash = "SOmECRAZYLONGHASHROFLCOPTERBBQKTHX"; | |
echo decrypt_whmcs($encoded_string, $cc_encryption_hash); | |
function decrypt_whmcs($encoded_string, $cc_encryption_hash) { | |
$key = md5(md5($cc_encryption_hash)) . md5($cc_encryption_hash); | |
$hash_key = _hash($key); | |
$hash_length = strlen($hash_key); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
/interface wireless channels | |
add band=2ghz-b/g/n width=20 list=2GHz/20MHz frequency=2412 name=ch1 | |
add band=2ghz-b/g/n width=20 list=2GHz/20MHz frequency=2437 name=ch6 | |
add band=2ghz-b/g/n width=20 list=2GHz/20MHz frequency=2462 name=ch11 | |
add band=5ghz-onlyac width=20 list=5GHz/80MHz extension-channel=Ceee frequency=5180 name=ch36/38/42 | |
add band=5ghz-onlyac width=20 list=5GHz/80MHz extension-channel=eCee frequency=5200 name=ch40/38/42 | |
add band=5ghz-onlyac width=20 list=5GHz/80MHz extension-channel=eeCe frequency=5220 name=ch44/46/42 | |
add band=5ghz-onlyac width=20 list=5GHz/80MHz extension-channel=eeeC frequency=5240 name=ch48/46/42 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/sh | |
# | |
# Read-only Root-FS for Raspian | |
# | |
# Modified 2016 by Stefan Bonfert to make it compatible with Raspbian | |
# Jessie (vanilla). | |
# | |
# Modified 2015 by Pascal Rosin to work on raspian-ua-netinst with | |
# overlayfs integrated in Linux Kernel >= 3.18. | |
# |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
################################################## | |
# Kill long queries # | |
# This shell script will kill queries that have # | |
# passed the $MAX execution time. # | |
# Julian Capilla-krumbak # | |
# [email protected] # | |
# 21-05-2014 # | |
################################################## | |
#!/bin/bash |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
## some useful aliases | |
alias ls "ls -h" | |
alias dir ls | |
alias less more | |
alias zless zmore | |
alias bzless bzmore | |
alias mirror "mirror -v" | |
alias sync "mirror -R -v -n" | |
alias reconnect "close; cache flush; cd ." | |
alias edit "eval -f \"get $0 -o ~/.lftp/edit.tmp.$$ && shell \\\"cp -p ~/.lftp/edit.tmp.$$ ~/.lftp/edit.tmp.$$.orig && $EDITOR ~/.lftp/edit.tmp.$$ && test ~/.lftp/edit.tmp.$$ -nt ~/.lftp/edit.tmp.$$.orig\\\" && put ~/.lftp/edit.tmp.$$ -o $0; shell rm -f ~/.lftp/edit.tmp.$$*\"" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
require("lsqlite3") | |
-- Igmar: Wanneer closen we dat DB object eigenlijk ? | |
db = sqlite3.open('/etc/asterisk/users.sqlite') | |
--CONSOLE = "Console/dsp" -- Console interface for demo | |
--CONSOLE = "DAHDI/1" | |
--CONSOLE = "Phone/phone0" | |
TRUNK = "DAHDI/G1" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/env python | |
import os | |
import subprocess | |
import time | |
# subprocess.check_output is not exist in python 2.6 which is on centos6 | |
# hostname = os.getenv("COLLECTD_HOSTNAME", subprocess.check_output(["hostname", "-f"]).strip()) | |
p = subprocess.Popen(["hostname", "-f"], stdout=subprocess.PIPE) |
On Tue Oct 27, 2015, history.state.gov began buckling under load, intermittently issuing 500 errors. Nginx's error log was sprinkled with the following errors:
2015/10/27 21:48:36 [crit] 2475#0: accept4() failed (24: Too many open files) 2015/10/27 21:48:36 [alert] 2475#0: *7163915 socket() failed (24: Too many open files) while connecting to upstream...
An article at http://www.cyberciti.biz/faq/linux-unix-nginx-too-many-open-files/ provided directions that mostly worked. Below are the steps we followed. The steps that diverged from the article's directions are marked with an *.
-
- Instead of using
su
to runulimit
on the nginx account, useps aux | grep nginx
to locate nginx's process IDs. Then query each process's file handle limits usingcat /proc/pid/limits
(wherepid
is the process id retrieved fromps
). (Note:sudo
may be necessary on your system for thecat
command here, depending on your system.)
- Instead of using
- Added
fs.file-max = 70000
to /etc/sysctl.conf - Added `nginx soft nofile 1
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
#!/bin/bash | |
current_time=$(date +%s) | |
target_time=$(date -d "$*" +%s) | |
seconds=$(( $target_time - $current_time )) | |
echo "sleeping $seconds (`date -d "$*"`)" | |
sleep $seconds | |
# Usage: |
NewerOlder