- Mac mini (Apple M1)
- OS: macOS 14.7
- ruby: ruby 3.3.4 (2024-07-09 revision be1089c8ec) [arm64-darwin23]
- ruby-build: ruby-build 20240917 (homebrew)
# Gemfile
PING6(8) System Manager's Manual PING6(8) | |
NAME | |
ping6 – send ICMPv6 ECHO_REQUEST packets to network hosts | |
SYNOPSIS | |
ping6 [-CDdfHmnNoqtvwW] [-a addrtype] [-b bufsiz] [-B boundif] [-c count] | |
[-G sweepmaxsize[,sweepminsize[,sweepincrsize]]] [-g gateway] | |
[-G sweep] [-h hoplimit] [-I interface] [-i wait] [-k trafficclass] | |
[-K netservicetype] [-l preload] [-P policy] [-p pattern] |
It is benchmarks about OpenStruct.
The ostruct gem warn bellow message with Warning[:performance] = true
OpenStruct use is discouraged for performance reasons
DEPRECATION WARNING: The success? predicate is deprecated and will be removed in Rails 6.0. Please use successful?
# deprecated
expect(response).to be_success
# spec/support/request_macros.rb | |
module RequestMacros | |
def request_login_user | |
before(:each) do | |
@loginuser = FactoryBot.create(:login_user) | |
post user_session_path, params: { user: { email: @loginuser.email, password: @loginuser.password } } | |
follow_redirect! | |
end | |
end | |
end |