Captive portal test
http://clients3.google.com/generate_204
http://www.gstatic.com/generate_204
http://172.217.6.238/generate_204
http://captiveportal.kuketz.de
https://e.foundation/net_204/
https://elementary.io/generate_204 \
<?xml version="1.0" encoding="UTF-8"?> | |
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> | |
<plist version="1.0"> | |
<dict> | |
<key>NSBonjourServices</key> | |
<array> | |
<string>_preflight_check._tcp</string> | |
</array> | |
</dict> | |
</plist> |
Hmm... I don't see any docs for 4.0 on https://webpack.js.org. I guess I'll just wing it.
All I need to do is npm i -D webpack@next
, right?
+ [email protected]
import * as Vuex from 'vuex'; | |
import 'reflect-metadata'; | |
export const TypeSymbol = Symbol('type'); | |
export interface IModule<R = any> { | |
readonly $state: any; | |
readonly $getters: any; | |
readonly $commit: Vuex.Commit; | |
readonly $dispatch: Vuex.Dispatch; |
#!/bin/sh | |
# Userland mode (~$USER/), (~/). | |
# ~/.fonts is now deprecated and that | |
#FONT_HOME=~/.fonts | |
# ~/.local/share/fonts should be used instead | |
FONT_HOME=~/.local/share/fonts | |
echo "installing fonts at $PWD to $FONT_HOME" | |
mkdir -p "$FONT_HOME/adobe-fonts/source-code-pro" |
#!/bin/bash | |
INSIDE_PREFIX="fdxx::/64" | |
OUTSIDE_INTERFACE="eth2" | |
DUMMY_INTERFACE="dummypd0" | |
OUTSIDE_PREFIX_FILE="/var/run/my-npt-outside-prefix" | |
logger -p info -t my-npt "my-npt-dhcp6c-script invoked" | |
OLD_OUTSIDE_PREFIX="" |
# jan/29/2018 22: 4:17 by RouterOS 6.41 | |
# | |
/interface list | |
add name=public comment="public network" | |
add name=local comment="local network" | |
add name=guest comment="guest network" | |
# Change the interfaces below to your own | |
/interface list member | |
add list=public interface=ether1 |
Model: MMC SEM32G (sd/mmc) | |
Disk /dev/block/mmcblk0: 31.9GB | |
Sector size (logical/physical): 512B/512B | |
Partition Table: gpt | |
Number Start End Size File system Name Flags | |
1 67.1MB 134MB 67.1MB fat16 modem | |
2 134MB 135MB 524kB sbl1 | |
3 135MB 135MB 32.8kB dbi | |
4 201MB 201MB 32.8kB DDR |
This is a list of tweaks to make IntelliJ IDEA work better with OpenJDK 8. Refer to System Properties for Java 2D Technology for the details of the options used below.
Note that the performance boost achieved via the OpenGL-based hardware acceleration pipeline is made possible by using the open-source Radeon driver (for AMD graphics cards) included in the latest stable version (10.3.3 as of now) of the Mesa 3D Graphics Library available in the official Fedora 21 stable repository. Therefore, the gained performance boost might vary based on the types of graphics cards and the versions of the drivers used in your system.
In $IDEA_HOME/bin/idea64.vmoptions
(or $IDEA_HOME/bin/idea.vmoptions
on a x86 architecture), change
LinuxでSoftCASとwpa supplicantを併用する
参考 https://gist.github.com/tyage/3d201580549bc84e24cd
LinuxでSoftCASを使う方法が公開されていたがlibpcscliteを書き換えるのでwpa supplicantと併用できない。恐らくwpa supplicantはWiFiだけでなくSIMカードを使った通信も制御していてpcscliteが必要なのだと思われる。
今回は併用することを目指す。
なおlibyakisobaというものもあるらしいが詳細不明。恐らくやりたいことは同じだと思われる